Техническая поддержка сервиса Quadro.Boards

Объявление

Новости сервиса

О форуме

Quadro.Support – это форум технической поддержки различных проектов и сервисов Quadro.Systems LLC, на котором грамотные технические специалисты всегда смогут помочь вам в решении проблем, или же подсказать ответы на самые сложные вопросы. Так же на форуме собрана обширная база знаний по различным аспектам наших сервисов. Не забывайте пользоваться поиском ;)

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Техническая поддержка сервиса Quadro.Boards » Скрипты и дополнения » Последние 10 сообщений в статистику


Последние 10 сообщений в статистику

Сообщений 21 страница 39 из 39

21

aulennatar
Начинать задавать вопросы надо хотя бы с рассказа о том, что за скрипт-то поставили. А то в теме их 5 и все разные.
Поставьте из первого поста (в хтмл-низ) и будет Вам счастье.

+1

22

Добрый день. Перестал работать этот скрит на форуме. В чем может быть проблема и есть ли альтернатива ему?

0

23

Nastena
У меня работает. Ставьте первый вариант в хтмл-низ:

Код:
<script src="/export.php?type=js&max=10" type="text/javascript"></script>
<script type="text/javascript">
var html='';
var ts = '';
var mo = '';
var hh = '';
var mm = '';
var i = 0;
for(i=0;i<content.length;i++) {
	ts = new Date();
	ts.setTime(1000*content[i][0]);
	mo = ts.getMonth()+1;
	if (mo<10) mo='0'+mo;
	hh = ts.getHours();
	mm = ts.getMinutes()+'';
	if (mm<10) mm='0'+mm;
	ts = ts.getDate()+'.'+mo+' '+hh+':'+mm;
html2="</tr></tbody></table></div>"
html1="<h2>Последние 10 сообщений форума</h2><div class=\"container\"><table cellspacing=\"0\" width=100%><thead><tr><th scope=\"col\">Автор</th><th scope=\"col\">Время</th><th scope=\"col\">Последнее сообщение</th></tr></thead><tbody class=\"hasicon\">"
html+='<tr><td>'+content[i][1]+'</td><td class=\"tc2\">'+ts+'<td class=\"tcr\"><a href=\"'+content[i][2]+'\" target=\"_blank\">'+content[i][3]+'</a><br /></td></tr>';
}

var arr=document.getElementsByTagName("div")
i=0
str=document.URL
while(arr[i] ){
if((str.substring(str.lastIndexOf('/')+1)=="" || str.substring(str.lastIndexOf('/')+1)=="index.php") && arr[i].className=="statscon"){
name=arr[i].innerHTML
name=name.substring(0)
arr[i].innerHTML=""+html1+""+html+""+html2+"<br><h2>Общая статистика</h2>"+name+""
}
i++
}
</script>

0

24

Стоит скрипт, добавляющий свою картинку в статистику.

вот этот

#pun-stats.section h2 {
background-attachment: scroll;
background-clip: border-box;
height: 120px;
width: 980px;
margin-left: -85px;
overflow-x: hidden;
color: transparent;
background-color: transparent;
background-image: url("адрес картинки");
padding-left: 50px;
background-origin: padding-box;
background-position: 50% 0%;
background-repeat: no-repeat;
background-size: auto;
font-size: 0px;}

И при добавлении скрипта вывода последних 10 сообщений, картинка со статистикой размножается.

И выглядит вот так

http://img-fotki.yandex.ru/get/3201/176512308.19/0_12a65c_21d9868c_orig

Как-то можно это исправить?

0

25

Mary
дело в том, что в скрипте есть заголовки, которые берут фон из #pun-stats.section h2
если не собираетесь в ближайшем будущем удалять скрипт 10 сообщений, то удалите фон из того кода, что дали и поставьте вот так:

Код:
#pun-stats {
  background: url("http://co.forum4.ru/files/0013/45/c5/89962.png") no-repeat scroll center top transparent;
}

(вообще лучше ссылку бы на тестовый, где стоит скрипт на всякий пожарный но думаю должно нормально встать)

(ну или как Дефф ниже написал)

Отредактировано Ichimaru Gin (27.10.2014 17:53:57)

0

26

Mary
Поставьте скрипт - сделайте скриншот, ткните стрелкой какой рисунок оставить или добавьте

#pun-stats.section h2:first-child {
background-attachment: scroll;
background-clip: border-box;
height: 120px;
width: 980px;
margin-left: -85px;
overflow-x: hidden;
color: transparent;
background-color: transparent;
background-image: url("адрес картинки");
padding-left: 50px;
background-origin: padding-box;
background-position: 50% 0%;
background-repeat: no-repeat;
background-size: auto;
font-size: 0px;}

0

27

Ichimaru Gin
Deff

Deff написал(а):

#pun-stats.section h2:first-child {


О, спасибо. Теперь все, как надо))

0

28

Добрый день.
Совершенно внезапно перестали отображаться последние 10 сообщений форума. Скрипты новые не ставились, ничего нигде не менялось, в настройки вообще никто не наведывался. Просто перестал работать на ровном месте и всё. Очень неудобно, фича зело полезная. В чём может быть причина и как исправить?

Адрес форума http://nightchildrengame.rusff.ru

Добавлено спустя 35 минут 1 секунду:
Заработало! Я так понимаю, с чьего-то высшего вмешательства. Спасибо за помощь :)

Отредактировано Рррыч (02.11.2014 13:28:52)

0

29

Рррыч
скрипт капризный, один лишний перенос строки и может слететь, внимательнее с ним.  У меня отобразился. Исправили уже?

Если нет, то браузер скажите и может быть какие-то плагины устанавливали себе?

Добавлено спустя 1 минуту 48 секунд:
Ну отлично тогда.
Принесем же жертву богам)

Отредактировано Ichimaru Gin (02.11.2014 13:31:16)

0

30

Нда, поработало полчаса и опять слетело. Напасть   :smoke:

0

31

Рррыч
вы ничего не трогали в настройках в это время?

Добавлено спустя 5 минут 19 секунд:
попробуйте удалить, сохранить и потом поставить обратно вариант из первого поста тут, ничего не меняя. Если скрипт заработает после этого, значит вы что-то задели\удалили.
Если не заработает, попробуйте еще переставить в самое начало HTML-низ

Добавлено спустя 2 часа 42 минуты 19 секунд:
Если не сработает, то можно попробовать убрать все из настроек и оставить только его. Если заработает, постепенно возвращайте и найдете, с чем конфликт
----
И если не заработает, то ждите садхаку.

Отредактировано Ichimaru Gin (02.11.2014 18:18:11)

0

32

Ichimaru Gin
В том и прикол, что то работает, то не работает произвольно. Отключилось, как уже говорил, вообще ни с того ни с сего, в администрирование даже никто не заглядывал, не то что что-то там трогать. После того как заметил (а заметил сразу, вот они были, эти десять сообщений, и вдруг уже нет),  пробовал переустановить скрипт по-новой, именно отсюда и взятый )) Переустанови, почистил кэш браузера - реакция нулевая. Через пол-часа или чуть больше скрипт заработал. Опять сам, никто больше ничего не трогал. Ещё через пол-часа или больше так же внезапно снова вырубился. То есть, конфликтов там быть не должно, ничего никто не ставил и не переустанавливал. Что и странно. Живёт, гад, своей жизнью, хочет - работает, не хочет - берёт выходной. Сам, без стороннего вмешательства.

0

33

Рррыч
секунду, протестирую у себя

Добавлено спустя 3 минуты 36 секунд:
У меня сейчас скрипт работает, у вас нет. Значит что-то у вас. Подождите скриптер скоро подойти должен.

Отредактировано Ichimaru Gin (02.11.2014 18:45:00)

0

34

Репит...

Отредактировано Deff (02.11.2014 20:38:21)

0

35

Рррыч,

Ники с Кавычками одинарными и двойными портят все скрипты:
Виктор "Кот" Хартли - зарегистрирован сегодня,
Сменить ему кавычки в Профиле(на Виктор «Кот» Хартли), выслать уведомление на Емейл

Отредактировано Deff (02.11.2014 20:33:41)

+3

36

Deff
Вот это да... Какой неожиданный эффект. Спасибо большое!

0

37

Добрый день!

Установил скрипт на тестовый форум, работает хорошо, но появилась какая-то лишняя чёрточка...
Подскажите, как это убрать?

http://sa.uploads.ru/UYbec.png

Ссылка на форум: http://a3atot.rusff.ru/

0

38

aa1976m
Найдите в скрипте (внизу почти) строчку
arr[i].innerHTML=""+html1+""+html+""+html2+"<br><h2>Общая статистика</h2>"+name+""

и удалите оттуда <br> (аккуратно, не задеть остальные символы) Станет так:
http://easycaptures.com/fs/uploaded/937/2674967033.png

+1

39

Ichimaru Gin

Спасибо! Теперь всё отлично :)

0


Вы здесь » Техническая поддержка сервиса Quadro.Boards » Скрипты и дополнения » Последние 10 сообщений в статистику


Рейтинг форумов | Создать форум бесплатно © 2007–2016 «QuadroSystems» LLC